انجمن‌های خارجی چند سالی است که در مورد نسخه پی اچ پی مناسب وردپرس بحث و گفت و گو دارند. بالاخره زمان استفاده از نسخه‌های پی اچ پی ۷ و بالاتر رسیده یا همچنان بهترین نسخه همان ۵٫۶ است!

در اجرایی که ما روی سایت جامه انجام دادیم در صورت نصب بودن وردپرس خام به همراه قالب‌های پیش‌فرض اجرا روی نسخه 7.4 بهتر از نسخه ۵٫۶ بود اما مشکل از جایی شروع می‌شود که تصمیم می‌گیرید از پلاگین ها و قالب‌های موجود در وب استفاده کنید. اکثر افزودنی‌های وردپرس مشکلاتی با نسخه‌های جدید پی اچ پی دارند.

وردپرس چه می گوید؟

وردپرس در وب سایت رسمی خود پیشنهاد داده که برای اجرای وردپرس از یک‌هاست که از نسخه php 7.4 و بالاتر پشتیبانی می‌کند استفاده کنید. وردپرس همچنین عنوان کرده که اجباری برای استفاده از نسخه ۷٫۳ و بالاتر نیست و وردپرس روی php 5.6 نیز به خوبی کار می‌کند. اما پیشنهاد می دهد به جهت مسائل امنیتی حتماً از آخرین نسخه php استفاده کنید.

همچنین در بخش سلامت وردپرس اگر نسخه php شما کمتر از 7.3 باشد به شما اعلام کند که وضعیت سلامت سایت شما خوب نیست.

وردپرس در کنار پی اچ پی پیشنهاد می‌دهد که از هاستینگی استفاده کنید که mysql 5.6 و بالاتر یا mariadb 10 و بالاتر روی آن نصب شده باشد.

پی اچ پی 5.6 , 7  و 7.1 دیگر پشتیبانی نمی شود

سال ۲۰۱۸ آخرین سالی بود که php 5.6 و php 7 پشتیبانی می‌شدند و عملاً در صورت وجود باگ‌ها امنیتی و مشکلات ساختاری در این نسخه‌ها هیچ به روز رسانی در کار نخواهد بود.

در سال 2019 نیز پشتیبانی نسخه 7.1 تمام شد.

کدام نسخه از php 7.x مناسب است

اولین نسخه از آن یعنی php 7.0 و 7.1 که مدتی است دیگر به روز رسانی‌های امنیتی را دریافت نمی‌کند.گزینه‌های پیش رو نسخه 7.2 و 7.3 و 7.4 پی اچ پی خواهد بود.

erlend eide یک فرایند بنچمارک روی این دو نسخه از php انجام داده و نتیجه آن به شرح زیر است.

PHP 7.2 میانگین: اجرای ۱۹۲ درخواست در ثانیه
PHP 7.3 میانگین: اجرای ۲۲۴ درخواست در ثانیه

از این بنچمارک می‌توان به این نتیجه رسید که php 7.3 در حدود ۱۷ درصد عملکرد بهتری نسبت php 7.2 دارد.

ضمن اینکه نسخه جدید php یعنی 7.4 در حدود 15 درصد از نسخه 7.3 سریع تر عمل میکند.

نسخه 7.2 پی اچ پی همچنان سازگارترین نسخه

بسیاری از افزونه ها و قالب های وردپرس با نسخه های جدید php سازگاری مناسبی ندارند. به همین خاطر در بیشتر مواقع اگر نسخه php هاست خود را روی 7.4 قرار دادید و سایت شما با ارور مواجه شد میتوانید به نسخه 7.2 تغییر دهید.

در مجموع می‌توان این‌طور نتیجه گیری کرد که بهتر است افزونه ها و قالب سایتتان را به نسخه های جدید به روز رسانی کنید و بعد php را به 7.4 ارتقا دهید.

فراموش نکنید که یک هاست وردپرس واقعی امکان ارتقا به php 7.4 را داراست.

یک دیدگاه ارسال کنید

خوشحالیم که دیدگاه خود را ارسال می کنید. چند نکته را در نظر داشته باشید.
1. دیدگاه شما حتما مرتبط با این محتوا باشد.
2. هیچ :)

جهت ثبت دیدگاه باید وارد شوید

دیدگاه های کاربران

حسین میرزائی
پی اچ پی 7.4 درست شد روی پی اچ پی 8 هم میبزارم بازم مینویسه هاست شما از MySQL پشتیبانی نمیکن برای این هم باید وردپرس رو اپدیت کنم و بعد افزونه ها رو غیر فعال کنم
پشتیبان جامه
درود ❤️ – php 8 هنوز نسخه پایدار نداره. از نسخه 7.4 استفاده کنید.
حسین میرزائی
سلام خسته نباشید من php رو روی 7.4 قرار دادم ولی وقتی صفحه اصلی سایت رو باز میکردم نوشته بود هاست شما از MySQL پشتیبانی نمیکنه این مشکل میدونید از چی هست
پشتیبان جامه
درود ❤️ – به کمک روش عیب یابی ابتدا با وردپرس را آپدیت کنید و سپس افزونه ها را غیر فعال و یکی یکی فعال کنید تا افزونه یا قالبی که ممکن است این مشکل را ایجاد کرده پیدا کنید.
masumi
سلام دوستان خسته نباشید. من یک سایت با وردپرس در لوکال طراحی کردم حالا میخام در شبکه یک سرکت برای کاربران به اشتراک بزارم. نکته اینجاست که این شرکت هیچگونه دسترسی به اینترنت ندارد.فقط اینترانت هسش(شبکه داخلی).چطوری میشه این چالش رو برطرف کرد؟؟؟؟؟
پشتیبان جامه
درود ❤️ – باید با مفاهیم شبکه کردن آشنا باشید. اما احتمالا بعد از شبکه کردن با وارد کردن آی پی 127.0.0.1 امکان دسترسی وجود داشته باشد.
علی
سلام من وقتی php 7.3 تنظیم میکنم سایتم دیگه بالا نمیاد
سروش احمدی
سلام خدمت شما احتمالا تعدادی از افزونه ها و قالب های شما قدیمی هست. بهتره قبل از هر چیز همه موارد رو به روز رسانی کنید.