راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

بعد از نصب افزونه‌ها و قالب‌های وردپرسی ممکن است مشکلاتی برای سایت شما پیش آید. از صفحه سفید مرگ تا تداخل افزونه‌ها و قالب‌ها که همگی جزو مشکلات عادی وردپرس هستند و برطرف کردن این مشکلات راه‌های بسیار آسانی دارد که در ادامه در مورد آن بیشتر صحبت می‌کنیم.

تمام محصولاتی که از سایت جامه دانلود می‌کنید همگی اورجینال هستند و بعد از نصب به کمک راهنمای زیر به راحتی می‌توانید مشکلات آن‌ها را رفع نمایید.

1- افزونه یا قالب فارسی نیست

تمام محصولات جامه فارسی هستند. درصورتی‌که بعد از نصب متوجه شدید محصول فارسی نیست ابتدا داشبورد وردپرس خود را فارسی کنید. این کار با باید از 2 بخش در وردپرس انجام دهید. از بخش تنظیمات عمومی وردپرس زبان سایت را فارسی قرار دهید و همچنین از بخش ویرایش شناسنامه کاربری زبان را روی پیش‌فرض قرار دهید.

در بعضی از مواقع وردپرس از کپی کردن فایل زبان افزونه یا قالب ناتوان است. در این موارد کافی است فایل زبان موجود در محصول را که با فرمت.mo هست را در پوشه مربوط به آن کپی کنید. در صورتی که فایل زبان متعلق به افزونه بود در پوشه \wp-content\languages\plugins کپی کنید و در صورتی مشکل در قالب بود فایل را در \wp-content\languages\themes کپی کنید.

برای انجام فرایند کپی کردن می‌توانید از فایل منیجر سی پنل و دایرکت ادمین و یا سرویس ftp کمک بگیرید.

2- تقویم خورشیدی (شمسی) ندارد

ممکن است برخی از قالب‌ها و افزونه‌ها در کل از تقویم خورشیدی پشتیبانی نکنند. اما در اکثر موارد دلیل آن استفاده نکردن شما از یک شمسی ساز وردپرسی است. در بخش افزودن افزونه در داشبورد وردپرس افزونه parsi date را جست‌وجو و نصب نمایید.

بعد از نصب تنظیمات بخش اول آن را کاملاً فعال کنید. (مطابق تصویر زیر)

راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

3- قالب یا افزونه لایسنس نیاز دارد

اکثر محصولاتی که در جامه مشاهده می‌کنید همان فایل اصلی قالب و افزونه بدون هر گونه دست‌کاری هستند. چرا جامه مشابه اکثر مارکت ها و سایت‌ها آن‌ها را نال نکرده است؟ دلیل اصلی این موضوع این است که سازنده قالب و افزونه به عمد خرید لایسنس را فقط برای بخش آپدیت خودکار قرار داده اما استفاده از آن کاملاً آزاد است.

این یکی از شیوه هاییست تا افرادی که از خرید یک محصول مطمئن نیستند ابتدا نسخه موجود در اینترنت آن را نصب کنند. به همین دلیل شما هم اکنون از یک محصول کاملاً اورجینال استفاده می‌کنید که ضمن فعال بودن از شما درخواست می‌کند تا برای آپدیت‌ها لایسنس نصب کنید.

شما می‌توانید با نصب افزونه Webcraftic Disable Admin Notices Individually از طریق داشبورد وردپرس پیام‌هایی که افزونه‌ها و قالب‌ها برای نصب لایسنس در داشبورد وردپرس نمایش می‌دهند را به راحتی مخفی کنید. و همچنین آپدیت هارا به صورت دستی از جامه دریافت کنید.

4- نسخه پی اچ پی هاست شما سازگار نیست

همانطور که می دانید وردپرس خیلی وقت است به شما پیشنهاد می‌دهد حداقل از پی اچ پی 7.3 یا 7.4 استفاده کنید. در صورتی که نسخه‌های قدیمی پی اچ پی را نصب دارید این احتمال وجود دارد که افزونه یا قالب به درستی کار نکند.

پس حتماً وردپرس را در حداقل به php 7.3 ارتقا دهید. در صورتی که روش کار را نمی‌دانید به هاستینگ خود تیکت بزنید تا آن‌ها برای شما انجام دهند.

5- قالب ها و افزونه های سایت شما به روز نیستند

در وردپرس بسیاری از محصولات تکمیل کننده یکدیگر هستند. به عنوان مثال قالب های فروشگاهی معمولا با افزونه ووکامرس کار می کنند و یا بسیاری از افزونه ها به کمک wpml ویژگی چند زبانه را ارائه می دهند. اینجاست که اگر افزونه ها و قالب های فعلی به روز نباشند ممکن است افزونه ها با یکدیگر به خوبی کار نکنند.

راهکار: افزونه های رایگان را از داشبورد و بخش به روز رسانی آپدیت کنید. سایر افزونه ها را نیز می توانید از جامه دانلود کنید و روی سایت خود آپدیت کنید.

6- دیتابیس سایت شما خراب است

با نصب تعداد زیادی افزونه و قالب ممکن است به خاطر تنظیمات اشتباه به مرور زمان دیتابیس شما خراب شود. این خرابی ممکن همیشه نمایان نشود اما در بعضی از مواقع مانند نصب محصول جدید با آن مواجه شوید.

اولین راه استفاده از ویژگی تعمیر خود وردپرس است. فایل wp-config.php در ریشه هاست را ویرایش کنید.

راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

define( 'WP_ALLOW_REPAIR', true );

کد زیر را به فایل اضافه کنید.

راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

بعد از آن طبق آدرس زیر وارد بخش تعمیر دیتابیس شوید.

http://yoursite.com/wp-admin/maint/repair.php

به جای yoursite.com آدرس سایت خودتان را وارد کنید. حتما http یا https را نیز به درستی وارد کنید.

راهنمای برطرف کردن مشکلات افزونه ها و قالب های وردپرسی

در این بخش فقط روی تعمیر پایگاه داده کلیک کنید. بعد از انجام فرایند تعمیر حتما کدی که در wp-config.php قرار داده اید را پاک کنید.

وردپرس در حد توان خود دیتابیس شما را تعمیر می کند. در صورتی که هنوز احساس می کنید مشکل دیتابیس پابرجاست آن را به یک کارشناس فنی بسپارید.

7- هاست شما منابع کمی دارد

وردپرس مشابه یک سیستم عامل برای اجرا نیاز به حداقل منابعی دارد. این میزان منابع با افزایش بازدید سایت شما نیز باید افزایش پیدا کند. اکثر هاستینگ ها برای ارزان کردن سرویس هایشان تعداد زیادی از سایت را در یک سرور میزبانی می کنند.

در صورت کمبود منابع ممکن است با نصب افزونه یا قالب جدید ارور های مختلفی از کمبود حافظه تا صفحه سفید و …. مشاهده کنید. به همین خاطر پیشنهاد میدهیم از یک هاستینگ معتبر یک هاست دارای منابع اختصاصی تهیه کنید.

8- افزونه ها و قالب ها ممکن است با یکدیگر تداخل داشته باشند

در وب سایت جامه بیش از 60 افزونه وردپرسی نصب شده است. اما هیچگونه فشاری به سرور ها وجود ندارد. در اصل این تعداد افزونه ها نیست که باعث ایجاد مشکل می شود. تداخل می تواند فشار شدیدی را به سرور های شما ایجاد کند.

در صورتی که تمام افزونه ها و قالب ها و البته خود وردپرس شما به روز است. و از پی اچ پی 7.3 به بالا استفاده می کنید می توانید برای پیدا کردن تداخل ها از افزونه Query Monitor استفاده کنید. این افزونه را به صورت رایگان از مخزن وردپرس نصب کنید.

این افزونه یک عیب یاب فوق العاده بی نظیر است و در صفحاتی که مشکلی مشاهده می کنید افزونه به شما اطلاع می دهد که مشکل از کجاست. در کنار این موضوع فعال کردن دیباگ نیز به شما کمک می کند.


چند توصیه مفید

همیشه بک آپ بگیرید

همیشه پیشنهاد میدهیم که به اکانت مدیریت فقط در مواقع ضروری وارد شوید. یک اکانت نویسنده برای خود ایجاد کنید و از طریق آن تولید محتوا کنید و دیدگاه هارا پاسخ دهید. هر زمان که تصمیم گرفتید برای انجام یک کار فنی مانند تنظیمات یا نصب و آپدیت قالب ها و افزونه ها وارد هاست یا اکانت مدیر شوید حتما قبل از آن بک آپ بگیرید.
در صورتی که وب سایت شما حجم زیادی دارد میتوانید به بک آپ گیری از دیتابیس بسنده کنید.

همیشه آخرین نسخه php را استفاده کنید

ممکن است به هاستینگ خود بگویید که آخرین نسخه از php را برای من تنظیم کن. و اعلام میکنند این نسخه موجود نیست و تفاوتی با نسخه های قدیمی ندارد!
این یک اشتباه بزرگ است. تمامی به روز رسانی های جدید پی اچ پی از نظر کارایی و سرعت به مراتب از نسخه های قبلی بهتر هستند. مثلا در تست بنچمارک مشخص شد که نسخه 7.3 در حدود 17 درصد عملکرد بهتری به نسبت 7.2 دارد وهمچنین نسخه 7.4 در مواردی تا 15 درصد عملکرد بهتری به نسبت 7.3 نشان می دهد.
جامه پیشنهاداتی برای شما داره

ارسال یک پاسخ

آدرس ایمیل شما منتشر نخواهد شد.